SharePointCommunity
Die deutschsprachige Community für SharePoint, Microsoft 365, Teams, Yammer und mit Azure

Filterpanel vom Termstore funktioniert seit dem 10.06. nicht mehr

bewertet von 0 Usern
Dieser Beitrag hat 0 Antworten | 2 Followers

Ohne Rang
Beiträge 2
StanNoack erstellt: 20 Aug 2020 15:22

 

Darstellung des Verhaltens

In einer Dokumentenbibliothek gibt es eine Spalte "Categories" welche Daten aus dem Termstore verwendet. Da es sich um hierarchische Daten handelt, wurde der Termstore verwendet.

 

Um für den User eine möglichste gute Usability zum Wiederauffinden seiner Dokumente zu gewährleisten, wurden in der Ansicht der Filterpanel zur Filterung der Categories angeheftet.

Der folgende Artikel von Microsoft beschreibt sehr gut das Verhalten und Design bis zum 09.06.2020:

https://support.microsoft.com/en-us/office/what-is-the-list-and-library-filters-pane-293561ed-fb2e-4fb2-9a9f-8a21e299e323

 

Die Darstellung war bis zum 09.06. eine Strukturansicht und funktioniert so, dass bei der Selektion eines Elementes alle untergeordneten Elemente bis zum letzten Element ebenso ausgewählt wurden. Dem User war es somit leicht möglich sein richtiges Dokument zu finden, da er auch die Filterung auf übergeordnete Elemente der hierarchischen Struktur mit Hilfe der Strukturansicht leicht auswählen konnte.

 

Seit dem 10.06. wird dieser Filterpanel nur noch als Listenauswahl dargestellt. Durch die große Baumstruktur ist das Auswählen der richtigen Elemente nicht mehr benutzerfreundlich, da man immer nur einen kompletten Pfad auswählen kann.

 

Seit dem 10.06. haben wir mittlerweile Erkenntnisse erarbeitet:

  1. Dieses veränderte Verhalten wirkt sich nur im Modern Layout aus. In der klassischen Darstellung ist die gewünschte  Funktionalität weiterhin gegeben, da man über die Metadatennavigation oder über die Spaltenfilterung den Punkte "untergeordnete Elemente" einblenden kann.

 

  1. Wir wissen, dass von Microsoft im Mai/Juni der Termstore auf Modern upgedated wurde.
    https://www.microsoft.com/en-us/microsoft-365/roadmap?rtc=1&filters=&searchterms=57315
    Wir vermuten hier einen Zusammenhang, haben aber keine letztlich eindeutigen Beweis dafür.
     
  2. Wir haben die verloren gegangene Funktionalität an Microsoft als Supportanfrage eskaliert und sind mittlerweile in der Bearbeitung durch die Produkt-Entwicklung angelangt. Aussage seit Juni ist: Es kann mehrere Wochen / Monate dauern bis es zu einer Lösung des vorliegenden Support Cases kommt.

 

  1. Die Funktionsbeeinträchtigung lässt sich auch in verschiedenen anderen Tenants nachstellen und auch bestehende andere Lösungen haben zwischenzeitlich das gleiche Verhalten gezeigt.

 

Wer kennt das Problem noch und her ggf. bereits erfolgreiche Ansätze / Workarounds entwickelt bzw. implementiert?

 

Seite 1 von 1 (1 Elemente) | RSS