SharePointCommunity
Die deutschsprachige Community für SharePoint, Microsoft 365, Teams, Yammer und mit Azure

ID

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 7 Antworten | 1 Follower

Ohne Rang
5 Beiträge
mark donner erstellt in 8 Nov 2010 11:49

Hallo

ich will die ID auswerten und z.B. alle 50 Abfragen eine Meldung erscheinen lassen. Das funktioniert auch aber nur gleich nach der Eingabe der Formel in späteren Zeilen dann nicht mehr. Auch für die Einfache Abfrage =ID gilt das. Hat jemand einen Tip?

Alle Antworten

Top-10-Beitragsschreiber
18.866 Beiträge

Kannst Du Deine Frage bitte nochmal neu formulieren? Ich habe jedenfalls kein Wort verstanden... Und fragst Du wirklich für SharePoint 2003?

Viele Grüße
Andi
af @ evocom de
Blog
Ohne Rang
5 Beiträge

Also:

Eine Spalte in einem Tabellenblatt soll die ID auswerten, so in der Art:

=WENN(ID/100=RUNDEN(ID/100;0);"Bitte prüfen und bestätigen";"")

alle 100 Eingaben soll damit eine Meldung erfolgen.

Die Formel funktioniert, nachdem die Spalte erstellt oder bearbeitet wurde in der nächsten Eingabezeile.

In einer weiteren Eingabezeile funktioniert sie nicht mehr.

Werte ich nur die ID aus mit: =ID

so erhalte ich in der ersten neuen Zeile die korrekte ID, in allen weiteren Zeile nach der Eingabe dann 0.

Verständlicher?

 

Ach ja, ich benutze WSS2007, Danke für die Nachfrage.

Top-10-Beitragsschreiber
18.866 Beiträge

Ja,verstanden.

Ich habe nur schnell die Formel =ID getestet. Das funktioniert bei mir auch nicht. Wenn man aber die Ausgabe als Zahl formatiert oder =TEXT(ID;"0") schreibt, dann geht es. Offenbar mußt Du da noch etwas am Format der ID basteln =ZAHL() oder so.

Viele Grüße
Andi
af @ evocom de
Blog
Ohne Rang
5 Beiträge

Hallo

vielen Dank für den Tip. Alles, was ich mit den Formaten oder Formeln versucht habe (auch =text(ID;"0"), funktoniert leider nur für die schon vorhandenen Elemete der  Liste, bei neuen Elementen wird wieder eine  0  ausgegeben.

Top-10-Beitragsschreiber
18.866 Beiträge

Das kann daran liegen, daß die ID erst NACH dem ersten Speichern festgelegt wird. Stimmt der Wert, wenn Du ein solches Element nochmal änderst?

Viele Grüße
Andi
af @ evocom de
Blog
Ohne Rang
5 Beiträge

Es funktioniert leider nicht. Eine Formel mit   ID  arbeitet jeweils einmalig für die ganze bisherige Liste nach beenden der Funktion Spalte bearbeiten.

Top-10-Beitragsschreiber
18.866 Beiträge

Die ID läßt sich offenbar wirklich nicht in berechneten Feldern verwenden. Du könntest aber einen Workflow machen, der die ID in ein anderes Feld kopiert. Oder einen Eventhandler programmieren.

Viele Grüße
Andi
af @ evocom de
Blog
Seite 1 von 1 (8 Elemente) | RSS